Started about 1 year agoJune 12, 2025Lasted about 3 hours6:309:30 PMUTC
Affected
Link
Major outage from 6:30 PM to 9:30 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved from Cloudflare.
Identified
UTC
Identified
UTC
We are currently impacted by the widespread outage affecting Cloudflare, a critical infrastructure provider. Our team is actively monitoring the situation.